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Working Model combines advanced motion simulation technology with sophisticated editing capabilities to
provide a complete, professional tool for engineering and animation simulation.    The dynamic simulation 
engine provides a translation of real world Newtonian mechanics to the computer, while the simple but 
powerful graphical user interface makes it easy to experiment with different scenarios and situations.

More about Working Model 

You can browse the following topics for more information about the features of Working Model:

Keyboard

Related Topics

Guided tour 
A word about copy protection 



A word about copy protection
We would like to thank you for purchasing one of our products.    At Knowledge Revolution, we are 
committed to providing you with quality products which are easy to use.    The product you have 
purchased is the result of thousands of hours of hard work by dedicated professionals.To provide quality, 
we are always listening to our most important source of feedback: customers like you.    We would like to 
know how you use our product and to know how we can better serve you.    We are constantly improving 
Working Model, and look forward to your comments and suggestions.    Please feel free to call me directly 
if I can be of service.

David Baszucki, President

Knowledge Revolution
66 Bovet Road, Suite 200
San Mateo, CA 94402

(415) 574-7777



 More about Working Model
Knowledge Revolutions Working Model® v2.0 combines advanced motion simulation technology with 
sophisticated editing capabilities to provide a complete, professional tool for engineering and animation 
simulation.    The dynamic simulation engine provides a translation of real world Newtonian mechanics to 
the computer, while the simple yet powerful graphical user interface makes it easy to experiment with 
various scenarios and situations.

Operating Concept

The operating concept of Working Model is simple.    Define a set of rigid bodies and constraints (e.g., 
motors, springs, and joints).    With a click of the mouse, Working Model uses its powerful simulation 
engine to put your model in motion.

Working Model allows you to fine-tune simulation parameters.    You can define controllers to adjust 
properties of objects.    You can create meters to plot the data that is taken during a simulation.    You can 
design a model in your favorite CAD program and import the data to Working Model.    You can even use 
another application such as Excel or MATLAB® to control your simulations.

Simulation Engine

The simulation engine of Working Model is designed for both speed and accuracy.    It calculates the 
motion of  interacting bodies using advanced numerical analysis techniques.    The engine allows the 
construction of complex systems, and computes their motion under a variety of constraints and forces.    
In addition to user-imposed constraints such as springs, pulleys, or joints, the engine has the capability to 
deal with world-level interactions, such as collisions, gravity, wind-resistance, and electrostatics.    The 
engine is fully configurable, and every aspect of a simulation from the time step (fixed or variable) to the 
integration technique can be specified by the user.      

Smart Editor

The Smart Editor is the core of the user interface, keeping track of connections and constraints among 
objects as they are constructed.    To develop a mechanism, a user simply starts to draw the components 
on the screen and indicates where and how the pieces should be joined.      The Smart Editor allows the 
mechanism to be rotated and dragged, while maintaining the fundamental integrity of the components and
of the joints between them.    Users can position objects by using the standard click-and-drag paradigm, or
by specifying their coordinates precisely in dialog boxes.    In all cases, the Smart Editor makes sure that 
no link is broken and no mass is stretched.    A robot arm, composed of many parts held together by pivot 
joints, can be positioned accurately using the Smart Editor.      By clicking and dragging the hand, the arm 
stretches out to the desired conformation.

Math coprocessor/FPU support

Working Model is designed to take full advantage your computer's math coprocessor (Floating Point Unit),
if one is available.    This speeds the computations enormously, allowing for faster, smoother animation.    
If no such unit is available, Working Model defaults to standard arithmetic.

Export of Data
Working Model imports and exports data to most popular CAD programs through the DXF file format.    

Input and Output Devices    
Real-time input devices include sliders, buttons, and text fields.    
Real-time output devices include graphs, digital displays, and bar displays.

Inter-Application Communication



Working Model uses DDE to communicate with other applications during a simulation.      Users can 
specify physical models of real-life mechanical designs and then control them externally through other 
programs.      For instance, a Microsoft® Excel worksheet can be used to model an external control 
system.      Data is sent to the spreadsheet, which calculates the control signals, and Working Model 
receives them, all while a simulation is in progress.

Although Working Model already provides a vast array of math functions, you can implement more 
advanced functions in another application and link them to a Working Model simulation.

Complete set of FastAction Buttons    

You can create a button to execute Working Model menu commands, including Run, Reset, and Quit.    
Buttons can simplify pre-made simulations for the first-time user.    With buttons, you can create Working 
Model documents that are similar to HyperCard stacks in that one document can lead to the next by the 
click of a button.

Text tool    

You can annotate simulations directly on the workspace, using any font, size, or style of text.

Moving Graphics    

You can paste pictures created with a paint or draw program directly on the workspace, as well as link 
them to objects.    For example, you can create a circular mass object and attach a picture of a baseball to
it.

Custom Global Forces    

You can now simulate planetary gravity as well as earth gravity, electrostatic forces, and air resistance 
proportional to velocity or velocity squared, or create your own custom global forces by supplying an 
equation.    For example, you can create magnetic fields, wind, and electron gun fields.

Extensive Graphical Features

You can show and hide objects, fill objects with patterns and colors, display how objects are charged (+ or
-), choose the thickness of an objects outline, show object names, display vectors in various ways and 
colors.

Multiple Reference Frames

You can now create different views using any mass or point as the frame of reference.    

Complete Control of Units

Choose from standard metric units such as kilograms, meters, and radians; standard English units such 
as foot, inch, yard, second, degrees, pounds; or other kinds of units such as light-years for measuring 
distance. 

Complete Scripting Language

Working Model has a scripting language for creating formulas that is very similar to the formula language 
used in Excel and Lotus 1-2-3.      

Equations

Any value can be a formula rather than a number.    For example, you can create a formula for a mass 
object that simulates a rocket, or create a formula for a force that simulates a sinusoidal driver.



No-Menu Player Documents

Player mode provides a simulation window with a limited menu bar and no palette, giving more room to 
display the simulation.    Player mode documents can be used by people who are not familiar with 
Working Model

Custom Tracking

You can track all objects or limit tracking to selected objects.    Individual objects can leave tracks of their 
outline, center of mass, or vectors.    You can also connect tracks with lines.

Object Layering

The simulation world consists of two layers:    one for user objects such as meters, and one for physical 
objects such as masses and constraints.    Full control of which objects collide is provided.

An Almost Infinite World

The simulation world can be as large as you like (up to ±1.0e4900 meters).    Zoom is infinite within the 
bounds of the world.

Vector Displays    

Working Model comes with a complete set of vector displays for showing velocity, acceleration, and force. 
Vectors can be displayed for electrostatic forces, for planetary forces, and at multiple contact points when 
two objects collide.

Save Time History

You can calculate and record complicated or time-consuming simulations overnight and play them back in
real time.    You can then save the entire simulation, to disk.

Group Center of Mass Object    

You can show the center of mass of all objects.    This feature is useful as a frame of reference for the 
center of mass in different views.

Pause Control    

Stop or pause simulations automatically.    For example, you can set the simulation to pause when two 
seconds have elapsed by entering the following formula:    Pause when time > 0.2.    You can also tell your
simulations to loop and reset.

Apply Control

You can apply forces and constraints at different times.    For example, you can apply a constant force on 
an object for one second, or you can apply a force when the objects velocity is greater than 10.

Unlimited Objects

You can create as many objects and constraints as your computers memory allows.    





 Guided tour
This guided tour uses sample experiments to help you learn how to use Working Model. Step-by-step 
instructions guide you through each task.

Starting Working Model 
Quick steps for creating a new experiment 
Running a sample experiment 
Setting up a simple experiment 
Measuring properties from an experiment 
Tracking objects 
Saving an experiment 
A projectile experiment with controls and menu buttons 



Starting Working Model

Have you installed Working Model on your hard disk? If not, please refer to the User's Manual for 
installation instructions.

1. Double-click the Working Model icon to start the program.
Working Model starts up and opens a new, untitled window.

The new, untitled experiment document appears in its own window. You will see the lab toolbox on the left
and the tape player controls along the bottom of the window.

The lab toolbox contains tools you will use to create experiments. Tools are provided for creating masses,
springs, ropes, forces, and many other objects. The lab toolbox also contains buttons for running and 
resetting experiments.

The tape player controls give you more control for running and viewing experiments. You can use the tape
player controls to step through experiments, play experiments backwards, or move to a specific time in an
experiment.



Quick steps for creating a new experiment

These quick steps provide an overview of how to use Working Model to create and run an experiment. 
Although the steps you take may differ depending on the type of experiment you are setting up, the basic 
steps for creating and running an experiment are as follows: 

1. Choose New from the File menu to open a new experiment document.
2. Draw and position mass objects and constraints.

Use the lab toolbox to draw objects just as you would with a paint or draw program.

3. Double-click an object to display and change its initial specifications (for example, velocity, 
friction, or elasticity).

4. Choose from the Measure menu to install meters and graphs that display the information to be
analyzed during the experiment.

5. Click Run in the lab toolbox.
6. Choose Save from the File menu to save the experiment.



Running a sample experiment

In this exercise, you will open and run sample experiment documents included with the program.

1. Choose Open from the File menu.
The Open dialog box appears.

2. Double-click any of the demonstration directories(animatio, engrng, tutorial) using the Open 
dialog box.
The contents of the demos folder appears.

3. Select one of the demonstrations in the list by clicking on it. Then click on the OK button.
4. Click Run in the lab toolbox.

The experiment will run.

6. To stop the experiment, click the mouse button.
Once you have finished watching an experiment, you should close it so that more memory is available
for other experiments.

7. Choose Close from the File menu to close the experiment window.
A dialog might appear asking if you want to save the changes before closing.

8. Click No in the dialog box.
To watch other demonstration experiments, repeat steps 1 through 8 above.

To finish your session with Working Model, choose Quit from the File menu.



Setting up a simple experiment

In this exercise, you will use tools from the lab toolbox to create a simple experiment. You will draw a 
circle to represent a projectile and specify its initial velocity. Then you will watch the projectile fly as you 
run the experiment.

Opening a new document
Drawing a circle
Moving the circle to its starting position
Specifying an initial velocity
Running the experiment





Opening a new document

If any experiment documents are currently open, close them before opening a new document.

1. Choose New from the File menu.
A new, untitled document window appears.

Next you will draw a circle to represent a mass.



Drawing a circle

The lab toolbox provides a variety of tools for setting up experiments. To choose a tool, click on it.

To draw a circle:

1. Click the Circle tool.
2. Position the pointer at any starting point in the blank area of the screen. 

The pointer changes from an arrow to a crosshair. This means you are ready to create an object.

3. Drag the mouse until the circle is the size you want. Then release the mouse button.
A line appears inside the circle. During an animated sequence, this line indicates the circle's rotation.



Moving the circle to its starting position

To position the circle for the start of the experiment:

1. Select the Arrow tool if it isn't already selected.
2. Position the pointer anywhere inside the circle.
3. Drag the circle to the lower left corner of the screen.



Specifying an initial velocity

To specify the initial velocity of the projectile:

1. Click the circle to select it.
Four square dots appear around the circle and one round dot appears at its center when it is 
selected. 

2. Position the pointer on the center dot in the circle and drag away from it to approximate the 
projectile's initial velocity.
While dragging, the arrow points away from the circle.

3. Release the mouse button at the desired initial velocity.
An arrow representing the projectile's initial velocity appears.

4. Drag the tip of the arrow to adjust the velocity.



Running the experiment

You are now ready to run your experiment. To run the experiment:

1. Click Run in the lab toolbox.
Voilá! Watch your first experiment run. Because normal earth gravity is on by default in a new 
document, the circle flies with the motion of a typical projectile.

2. Click once to stop the experiment.
3. Click Reset in the lab toolbox to rewind the experiment.
4. Go back to step 4 under Specifying an initial velocity and try running this experiment with 

different velocities.



Measuring properties from an experiment

Working Model allows you to measure many physical properties such as velocity, acceleration, and 
energy by using meters and vectors.

Meters and vectors provide visual representations of quantities you want to measure. Meters can display 
information in the physics world as:

numbers (digits)
level indicator (bars)
graphs

Vectors represent the properties of velocity, acceleration, and force as visual arrows. The direction of the 
arrow shows the direction of the velocity, acceleration, or force. The length of the arrow corresponds to 
the magnitude of the velocity, acceleration, or force.

In the following exercises, you will measure a projectile's velocity and display it in various ways. First, you 
will display it as a digital meter. Then you will change that meter to a graph. Finally, you will display the 
velocity of the projectile as an animated vector.

Displaying a velocity meter
Changing to a graphical display
Displaying vectors



Displaying a velocity meter

To display a digital meter that measures the velocity of the projectile, follow these steps:

1. Click Reset in the lab toolbox.
2. Draw a circle in the lower left-hand corner of the workspace if you don't already have one. 

Select the circle.
The circle becomes selected: four small dots and the velocity arrow appear. If you already know how 
to create objects and give them initial velocities, just create a single circular mass, and give it an initial
velocity.

3. Choose Velocity from the Measure menu, and All from the Velocity sub menu.
A digital velocity meter appears.

4. Click Run in the lab toolbox.
As the projectile flies, you can monitor its velocity by watching the velocity meter.

5. Click on the Stop button to stop the experiment.



Changing to a graphical display

To change a digital meter into a graph:

1. Click Reset in the lab toolbox to rewind the experiment.
2. Click the arrow in the top left corner of the meter.

The meter becomes a graph. The graph shows all of the values that were originally displayed on the 
digital meter. To view one particular property, click the buttons on the side of the graph until the 
desired property is the only one displayed. 

Choices that are gray will not be displayed. Choices that are white will be displayed.

3. Select Vy as the only property to be graphed by clicking in the buttons on the side of the 
meter.

4. Click Run in the lab toolbox.
5. Click the Stop button to stop the experiment.
You can install meters to measure every quantity shown in the Measure menu.



Displaying vectors

To display the velocity of the projectile as an animated vector:

1. Select the circle.
2. Choose Velocity from the Vectors menu.
3. Click Run in the lab toolbox.

When you run the experiment, a vector appears on the circle, showing its velocity. 

4. Click on the Stop button to stop the experiment.



Tracking objects

Tracking shows the path of an object by recording its location at specific intervals. The following 
instructions generate an illustration you may be familiar with from physics textbooks.

1. Click Reset in the lab toolbox if you have run and not yet reset the experiment.
2. Choose Tracking from the World menu, and then choose Every 8 frames from the sub menu.

When you run the experiment, Working Model will display the position of the circle every eight frames.

4. Click Run in the lab toolbox.
The projectile's path is traced as it flies.

5. Click once to stop the experiment.
The track will be erased when you create or edit objects.



Saving an experiment

Once your experiment is complete, you can save it to replay or edit later.

To save an experiment to disk:

1. Choose Save from the File menu.
The Save As dialog box appears if you have not yet given the experiment a name.

2. Type a name for your experiment document. Then click OK.
When you save an experiment document, the changes you made in all dialog boxes are saved too.

If you have already selected and entered a name for your experiment you can perform sequential saves 
without interrupting your work.

Use the Save As command to save a copy of your experiment under a different name.



A projectile experiment with controls and menu buttons

In this tutorial you will create a projectile experiment with controls and sliders. The experiment will be 
similar to launching a golf ball off the edge of a cliff, or rolling a ball off the edge of a table. You will be able
to control the velocity of the projectile with a slider on the screen. You will also use buttons to make a 
simple, stand-alone experiment that can be easily used by others with little or no experience using 
Working Model.

Making the projectile experiment
Creating controls
Creating menu buttons
Player documents



Making the projectile experiment

To make the projectile experiment:

1. Create a new Working Model document by choosing New from the File menu.
2. Select the Circle tool and create a small circular mass in the middle of the workspace.
3. Select the Rectangle tool and create a rectangle right below the circle.

You create a rectangle in the same way you create circles. Click the Rectangle tool in the lab toolbox, 
and then draw the rectangle on the screen. 

4. Click the tool that looks like an anchor.
The pointer becomes an anchor.

5. Click the anchor once on the rectangle.
An anchor appears on the rectangle. The rectangle is now anchored. It will not move when you run 
the experiment.

6. Click Run in the lab toolbox.
The circle bounces a few times and then comes to rest on the rectangle.

7. Click Reset in the lab toolbox.



Creating controls

You will now create an experiment with an initial velocity control. In this experiment, the circle will act as a 
projectile that is fired horizontally from the left. You will use a slider control to change the initial velocity of 
the projectile (circle).

1. Drag the rectangle to the bottom-right portion of the document.
2. Select the circle.
3. Choose New Control from the Define menu. Choose Initial X Velocity from the sub menu.

A new control appears. This control specifies the initial velocity of the circle in the x (horizontal) 
direction.

4. Pick an initial x velocity for the circle by using the slider to raise or lower the value.
5. Run the experiment.

Try to hit the rectangular pad by choosing the correct velocity. Reset the experiment to try again.



Creating menu buttons

You will now add menu buttons to create a simple lab for use by others who are not familiar with Working 
Model.

1. Choose New Menu Button from the Define menu.
A dialog box appears asking you to choose the menu command that you want the new button to 
perform.    A list of all menu commands and actions is displayed alphabetically.

2. Choose Run from the list.
The button appears with the name Run. Clicking on this button is the same as choosing Run from the 
Wolrd menu.

3. Click the Run button to watch the experiment.
4. Reset the experiment.
5. Choose New Menu Button from the Define menu.
6. Choose Reset from the list.

You now have a document with two menu buttons.

To move a menu button:

1. Click near the button's border or drag a selection rectangle around the button to select it.
Four selection handles appear around the button.

2. Position the pointer near the selected button until the pointer changes to a crosshair.
3. Drag the button to the desired location.



Player documents

Finally, you will change this document into a player experiment. Player experiments are good for 
demonstrations, and for use by others.

Player experiments have no palette. Objects in player experiments cannot be dragged or resized. Menus 
in player experiments are greatly simplified.

1. Choose Player Mode from the Edit menu.
The palette disappears and the experiment becomes a player experiment.

2. You can run the experiment by clicking on the Run button





 Keyboard commands
You can use modifier keys in addition to the mouse    to constrain shapes when drawing objects.    Many 
Working Model menu items can be chosen with keyboard keys instead of using the mouse.    These are 
called keyboard shortcuts.    For example, pressing the F1 key is the same as choosing the Help menu.

Modifier keys
Keyboard shortcuts



Modifier keys
The following list explains modifier keys that you can use when editing objects.    Modifier keys can be 
used in conjunction with the zoom tools to toggle between Zoom In and Zoom Out.

Using the Shift key
To select more than one item, hold down the Shift key while clicking the items you want.

Clicking on an already selected object while holding down the Shift key deselects the object.

Using the Control key
Holding down the Control key while dragging the end point of a constraint will maintain its current length.   
Control-drag will also maintain the current connections of constraints and mass objects.



Keyboard shortcuts

Key Action
+ Steps forward one frame

Control F1 Join

- Steps backward one frame

Control F2 Split

Shift-Control-R Runs from the last computed frame

Space bar Selects the Arrow tool

r, R Select the Rotation tool

a, A Select the Anchor tool

z Selects the Zoom in tool

Z Selects the Zoom out tool

Alt-Enter Invokes the object Properties window

Alt-Backspace Undo

Delete Clear

Shift-Delete Cut

Control-Insert Copy

Shift-Insert Paste

F1 Help

F2 New document

Alt-F4 Quit

F5 Run/Stop

F12 Save As

Shift-F12 Save

Control-F12 Open

Control-Shift-F12 Print





 High Accelerations
This warning dialog appears when objects undergo accelerations large enough to change velocity by 1/5 
the amount of the high velocity threshold in one simulation step.

High accelerations can be an indication that the system needs a smaller or variable (Accurate mode) time
step to be accurately simulated.    High accelerations can result from forces which are extremely large.

Try reducing the value of Time Step in the Accuracy dialog box for better accuracy.



 High Velocities
This warning dialog appears when objects have a velocity large enough to move 20 times the maximum 
error distance in the current simulation step.    This behavior may cause a loss of accuracy, or irregular 
collisions.

Try reducing the value of Time Step in the Accuracy dialog box to decrease the distance traveled by 
objects between each simulation step.



 Redundant Constraints
This warning dialog appears when more constraints are being used than are necessary to constrain a 
specific object's motion. For example, a mass object with several pin joints between it and the 
background is redundantly constrained.    

One or more of the constraints will be ignored.



 Inconsistent Constraints
This warning dialog appears when conflicting constraints are being used, and the situation cannot be 
solved. For example, when a mass driven by a constant velocity motor hits a second, anchored mass.

One or more of the constraints will be ignored.



 Initial Mass Overlap
This warning dialog appears when two or more masses overlap by more than the set tolerance, and the 
objects are not connected by joints or designated as Do Not Collide.

When two overlapping objects collide, they may cause physical instability in the simulation.    The 
overlapping objects should be designated as Do Not Collide by selecting the objects and using the Do Not
Collide option in the Object menu.    If the objects need to collide and the message appears at frame 0, 
then the objects need to be moved apart so they no longer overlap;    if the message appears at a later 
frame you should reduce the time step or set accuracy to Accurate mode.






